{"id":"CVE-2024-42360","revision":"33a0fd31a4984c7aa3581329d3dc1751","records":[{"revision":"33a0fd31a4984c7aa3581329d3dc1751","observedAt":"2026-10-29T15:12:12.364+00:00","statement":{"source":"cve-program","id":"CVE-2024-42360","aliases":[],"title":"Command Injection in sequenceserver","description":"SequenceServer lets you rapidly set up a BLAST+ server with an intuitive user interface for personal or group use. Several HTTP endpoints did not properly sanitize user input and/or query parameters. This could be exploited to inject and run unwanted shell commands. This vulnerability has been fixed in 3.1.2.","state":0,"publishedAt":"2024-08-14T19:50:09.469+00:00","modifiedAt":"2026-10-29T13:29:01.622+00:00","affected":[{"ecosystem":"Vendor product","name":"sequenceserver","ranges":[],"versions":[],"rawVersionEvidence":"{\n                    \"vendor\": \"wurmlab\",\n                    \"product\": \"sequenceserver\",\n                    \"versions\": [\n                        {\n                            \"version\": \"< 3.1.2\",\n                            \"status\": \"affected\"\n                        }\n                    ]\n                }"}],"metrics":[{"system":"CVSS 3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8,"severity":"CRITICAL"}],"references":["https://github.com/wurmlab/sequenceserver/security/advisories/GHSA-qv32-5wm2-p32h","https://github.com/wurmlab/sequenceserver/commit/457e52709f7f9ed2fceed59b3db564cb50785dba"],"sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2024-42360","license":"CVE Program Terms of Use","key":"cve-program:CVE-2024-42360","identifiers":["CVE-2024-42360"]},"retained":false,"historicalAffected":[]}],"coverage":[]}