{"id":"CVE-2025-53092","revision":"15c1715fe25c48daab062db4a212c873","records":[{"revision":"15c1715fe25c48daab062db4a212c873","observedAt":"2026-10-23T15:48:27.903+00:00","statement":{"source":"cve-program","id":"CVE-2025-53092","aliases":[],"title":"Strapi core vulnerable to sensitive data exposure via CORS misconfiguration","description":"Strapi is an open source headless content management system. Strapi versions prior to 5.20.0 contain a CORS misconfiguration vulnerability in default installations. By default, Strapi reflects the value of the Origin header back in the Access-Control-Allow-Origin response header without proper validation or whitelisting. This allows an attacker-controlled site to send credentialed requests to the Strapi backend. An attacker can exploit this by hosting a malicious site on a different origin (e.g., different port) and sending requests with credentials to the Strapi API. The vulnerability is fixed in version 5.20.0. No known workarounds exist.","state":0,"publishedAt":"2025-10-16T16:29:35.246+00:00","modifiedAt":"2025-10-16T18:13:08.618+00:00","affected":[{"ecosystem":"Vendor product","name":"strapi","ranges":[],"versions":[],"rawVersionEvidence":"{\n                    \"vendor\": \"strapi\",\n                    \"product\": \"strapi\",\n                    \"versions\": [\n                        {\n                            \"version\": \"< 5.20.0\",\n                            \"status\": \"affected\"\n                        }\n                    ]\n                }"}],"metrics":[{"system":"CVSS 3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N","score":6.5,"severity":"MEDIUM"}],"references":["https://github.com/strapi/strapi/security/advisories/GHSA-9329-mxxw-qwf8"],"sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2025-53092","license":"CVE Program Terms of Use","key":"cve-program:CVE-2025-53092","identifiers":["CVE-2025-53092"]},"retained":false,"historicalAffected":[]}],"coverage":[]}