{"id":"CVE-2026-111907","revision":"7336f7dcc858414b930467a3d3fb6318","records":[{"revision":"7336f7dcc858414b930467a3d3fb6318","observedAt":"2026-10-23T15:48:27.903+00:00","statement":{"source":"cve-program","id":"CVE-2026-111907","aliases":[],"title":"phpMyFAQ 4.0.0 before 4.1.9 CSRF via /admin/api/update-database","description":"phpMyFAQ 4.0.0 before 4.1.9 contains a cross-site request forgery vulnerability in the POST /admin/api/update-database endpoint, which executes database migrations without validating a CSRF token. Attackers can lure a logged-in user with the CONFIGURATION_EDIT permission into submitting a crafted cross-site request, triggering migrations that may impact database integrity or availability.","state":0,"publishedAt":"2026-10-17T18:46:26.117+00:00","modifiedAt":"2026-10-19T16:39:51.053+00:00","affected":[{"ecosystem":"Vendor product","name":"phpMyFAQ","ranges":[],"versions":[],"rawVersionEvidence":"{\n                    \"vendor\": \"thorsten\",\n                    \"product\": \"phpMyFAQ\",\n                    \"defaultStatus\": \"unaffected\",\n                    \"versions\": [\n                        {\n                            \"version\": \"4.0.0\",\n                            \"status\": \"affected\",\n                            \"versionType\": \"semver\",\n                            \"lessThan\": \"4.1.9\"\n                        },\n                        {\n                            \"version\": \"4.1.9\",\n                            \"status\": \"unaffected\",\n                            \"versionType\": \"semver\"\n                        }\n                    ]\n                }"}],"metrics":[{"system":"CVSS 4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N","score":7.1,"severity":"HIGH"},{"system":"CVSS 3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:H","score":7.1,"severity":"HIGH"}],"references":["https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-6x9g-rfx8-g42q","https://www.vulncheck.com/advisories/phpmyfaq-4.0.0-before-4.1.9-csrf-via-admin-api-update-database"],"sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-111907","license":"CVE Program Terms of Use","key":"cve-program:CVE-2026-111907","identifiers":["CVE-2026-111907"]},"retained":false,"historicalAffected":[]}],"coverage":[]}