{"id":"CVE-2026-112362","revision":"fae2e539520c473aba6e848e2aeaa2f5","records":[{"revision":"fae2e539520c473aba6e848e2aeaa2f5","observedAt":"2026-10-27T13:09:22.002+00:00","statement":{"source":"cve-program","id":"CVE-2026-112362","aliases":[],"title":"@fastify/express vulnerable to path-scoped middleware bypass via absolute-form request targets","description":"@fastify/express is a Fastify plugin that runs Express middleware inside Fastify. In versions 4.0.5 through 4.0.8, when Fastify runs with the non-default ignoreDuplicateSlashes option enabled, the plugin matches path-scoped Express middleware against a URL whose duplicate-slash normalization has also collapsed the separator after an absolute-form request target's scheme, so Fastify's router resolves the request to the scoped path and runs the handler while the Express layer no longer sees that path. As a result, a request using an absolute-form target can reach a handler on a scoped route such as an admin path while the middleware for authentication, authorization, or rate limiting is skipped. An unauthenticated attacker needs only the non-default ignoreDuplicateSlashes option to be enabled. The issue is fixed in @fastify/express 4.0.9, and users should upgrade to 4.0.9 or later. As a workaround, enforce authentication in a Fastify hook such as preHandler that runs after the router resolves the request, or leave ignoreDuplicateSlashes at its default.","state":0,"publishedAt":"2026-10-27T11:27:59.364+00:00","modifiedAt":"2026-10-27T11:27:59.364+00:00","affected":[{"ecosystem":"Vendor product","name":"@fastify/express","ranges":[],"versions":[],"rawVersionEvidence":"{\n                    \"vendor\": \"@fastify/express\",\n                    \"product\": \"@fastify/express\",\n                    \"defaultStatus\": \"unaffected\",\n                    \"versions\": [\n                        {\n                            \"versionType\": \"semver\",\n                            \"status\": \"affected\",\n                            \"version\": \"4.0.5\",\n                            \"lessThan\": \"4.0.9\"\n                        },\n                        {\n                            \"versionType\": \"semver\",\n                            \"status\": \"unaffected\",\n                            \"version\": \"4.0.9\"\n                        }\n                    ],\n                    \"packageURL\": \"pkg:npm/@fastify/express\"\n                }"}],"metrics":[{"system":"CVSS 3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","score":9.1,"severity":"CRITICAL"}],"references":["https://github.com/fastify/fastify-express/security/advisories/GHSA-6h42-57hq-9746","https://cna.openjsf.org/security-advisories.html"],"sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-112362","license":"CVE Program Terms of Use","key":"cve-program:CVE-2026-112362","identifiers":["CVE-2026-112362"]},"retained":false,"historicalAffected":[]}],"coverage":[]}