{"id":"CVE-2026-41268","revision":"a4d5e4bb334b46f9b86b48e4cc83230c","records":[{"revision":"a4d5e4bb334b46f9b86b48e4cc83230c","observedAt":"2026-10-23T15:48:27.903+00:00","statement":{"source":"cve-program","id":"CVE-2026-41268","aliases":[],"title":"Flowise: Flowise Parameter Override Bypass Remote Command Execution","description":"Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, Flowise is vulnerable to a critical unauthenticated remote command execution (RCE) vulnerability. It can be exploited via a parameter override bypass using the FILE-STORAGE:: keyword combined with a NODE_OPTIONS environment variable injection. This allows for the execution of arbitrary system commands with root privileges within the containerized Flowise instance, requiring only a single HTTP request and no authentication or knowledge of the instance. This vulnerability is fixed in 3.1.0.","state":0,"publishedAt":"2026-04-23T19:13:36.22+00:00","modifiedAt":"2026-04-23T20:19:47.223+00:00","affected":[{"ecosystem":"Vendor product","name":"Flowise","ranges":[],"versions":[],"rawVersionEvidence":"{\n                    \"vendor\": \"FlowiseAI\",\n                    \"product\": \"Flowise\",\n                    \"versions\": [\n                        {\n                            \"version\": \"< 3.1.0\",\n                            \"status\": \"affected\"\n                        }\n                    ]\n                }"}],"metrics":[{"system":"CVSS 3.0","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L","score":7.7,"severity":"HIGH"}],"references":["https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-cvrr-qhgw-2mm6"],"sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-41268","license":"CVE Program Terms of Use","key":"cve-program:CVE-2026-41268","identifiers":["CVE-2026-41268"]},"retained":false,"historicalAffected":[]}],"coverage":[]}