{"id":"CVE-2026-42334","revision":"864f2b54b0ed427894ac9853c3568189","records":[{"revision":"864f2b54b0ed427894ac9853c3568189","observedAt":"2026-10-23T15:48:27.903+00:00","statement":{"source":"cve-program","id":"CVE-2026-42334","aliases":[],"title":"Mongoose: Improper Sanitization of $nor in sanitizeFilter May Allow NoSQL Injection","description":"Mongoose is a MongoDB object modeling tool designed to work in an asynchronous environment. Prior to 6.13.9, 7.8.9, 8.22.1, and 9.1.6, a vulnerability allows bypassing Mongoose’s sanitizeFilter query sanitization mechanism via the $nor operator. When sanitizeFilter is enabled, Mongoose wraps query operators in $eq to neutralize them. However, prior to the fix, $nor was not included in the set of logical operators that are recursively sanitized. Because $nor accepts an array (like $and and $or), and arrays do not trigger hasDollarKeys(), malicious operators such as $ne, $gt, or $regex could be injected inside a $nor clause without being sanitized. This vulnerability is fixed in 6.13.9, 7.8.9, 8.22.1, and 9.1.6.","state":0,"publishedAt":"2026-05-14T18:03:43.196+00:00","modifiedAt":"2026-05-14T18:18:06.935+00:00","affected":[{"ecosystem":"Vendor product","name":"mongoose","ranges":[],"versions":[],"rawVersionEvidence":"{\n                    \"vendor\": \"Automattic\",\n                    \"product\": \"mongoose\",\n                    \"versions\": [\n                        {\n                            \"version\": \"< 6.13.9\",\n                            \"status\": \"affected\"\n                        },\n                        {\n                            \"version\": \">= 7.0.0, <= 7.8.8\",\n                            \"status\": \"affected\"\n                        },\n                        {\n                            \"version\": \">= 8.0.0, <= 8.22.0\",\n                            \"status\": \"affected\"\n                        },\n                        {\n                            \"version\": \">= 9.0.0, <= 9.1.5\",\n                            \"status\": \"affected\"\n                        }\n                    ]\n                }"}],"metrics":[{"system":"CVSS 3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","score":7.5,"severity":"HIGH"}],"references":["https://github.com/Automattic/mongoose/security/advisories/GHSA-wpg9-53fq-2r8h"],"sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-42334","license":"CVE Program Terms of Use","key":"cve-program:CVE-2026-42334","identifiers":["CVE-2026-42334"]},"retained":false,"historicalAffected":[]}],"coverage":[]}