{"id":"CVE-2026-44580","sourceIdentifier":"security-advisories@github.com","published":"2026-05-13T18:16:18.260","lastModified":"2026-10-26T14:10:00.130","vulnStatus":"Analyzed","cveTags":[],"descriptions":[{"lang":"en","value":"Next.js is a React framework for building full-stack web applications. From 13.0.0 to before 15.5.16 and 16.2.5, applications that use beforeInteractive scripts together with untrusted content can be vulnerable to cross-site scripting. In affected versions, serialized script content was not escaped safely before being embedded into the document, which could allow attacker-controlled input to break out of the intended script context and execute arbitrary JavaScript in a visitor's browser. This vulnerability is fixed in 15.5.16 and 16.2.5."},{"lang":"es","value":"Next.js es un React framework para construir aplicaciones web full-stack. Desde la versión 13.0.0 hasta antes de la 15.5.16 y 16.2.5, las aplicaciones que usan scripts beforeInteractive junto con contenido no confiable pueden ser vulnerables a cross-site scripting. En las versiones afectadas, el contenido de script serializado no se escapaba de forma segura antes de ser incrustado en el documento, lo que podría permitir que la entrada controlada por el atacante saliera del contexto de script previsto y ejecutara JavaScript arbitrario en el navegador de un visitante. Esta vulnerabilidad está corregida en las versiones 15.5.16 y 16.2.5."}],"affected":[{"source":"security-advisories@github.com","affectedData":[{"vendor":"vercel","product":"next.js","versions":[{"version":">= 13.0.0, < 15.5.16","status":"affected"},{"version":">= 16.0.0, < 16.2.5","status":"affected"}]}]}],"metrics":{"cvssMetricV31":[{"source":"security-advisories@github.com","type":"Secondary","cvssData":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","baseScore":6.1,"baseSeverity":"MEDIUM","attackVector":"NETWORK","attackComplexity":"LOW","privilegesRequired":"NONE","userInteraction":"REQUIRED","scope":"CHANGED","confidentialityImpact":"LOW","integrityImpact":"LOW","availabilityImpact":"NONE"},"exploitabilityScore":2.8,"impactScore":2.7}],"ssvcV203":[{"source":"134c704f-9b21-4f2e-91b3-4a467353bcc0","ssvcData":{"timestamp":"2026-05-13T18:28:00.345033Z","id":"CVE-2026-44580","options":[{"exploitation":"none"},{"automatable":"no"},{"technicalImpact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}]},"weaknesses":[{"source":"security-advisories@github.com","type":"Secondary","description":[{"lang":"en","value":"CWE-79"}]}],"configurations":[{"nodes":[{"operator":"OR","negate":false,"cpeMatch":[{"vulnerable":true,"criteria":"cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:*","versionStartIncluding":"13.0.0","versionEndExcluding":"15.5.16","matchCriteriaId":"38F6033B-EE4D-4FA6-8C47-0A11A6870E85"},{"vulnerable":true,"criteria":"cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:*","versionStartIncluding":"16.0.0","versionEndExcluding":"16.2.5","matchCriteriaId":"27C5CF7A-7A33-4BE4-B8FD-10BFD813204A"}]}]}],"references":[{"url":"https://github.com/vercel/next.js/security/advisories/GHSA-gx5p-jg67-6x7h","source":"security-advisories@github.com","tags":["Mitigation","Vendor Advisory"]}]}