{"id":"CVE-2026-44580","revision":"8d74c0130690467e827cf8e7554458d8","records":[{"revision":"8d74c0130690467e827cf8e7554458d8","observedAt":"2026-10-25T10:17:27.754+00:00","statement":{"source":"nvd","id":"CVE-2026-44580","aliases":[],"title":"Next.js is a React framework for building full-stack web applications. From 13.0.0 to before 15.5.16 and 16.2.5, applications that use beforeInteractive scripts together with untrusted content can be vulnerable to cross-site scripting. In a…","description":"Next.js is a React framework for building full-stack web applications. From 13.0.0 to before 15.5.16 and 16.2.5, applications that use beforeInteractive scripts together with untrusted content can be vulnerable to cross-site scripting. In affected versions, serialized script content was not escaped safely before being embedded into the document, which could allow attacker-controlled input to break out of the intended script context and execute arbitrary JavaScript in a visitor's browser. This vulnerability is fixed in 15.5.16 and 16.2.5.","state":0,"publishedAt":"2026-05-13T18:16:18.26+00:00","modifiedAt":"2026-06-17T10:50:49.77+00:00","affected":[],"metrics":[{"system":"CVSS 3.1 · security-advisories@github.com · Secondary","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1,"severity":"MEDIUM"}],"references":["https://github.com/vercel/next.js/security/advisories/GHSA-gx5p-jg67-6x7h"],"sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-44580","license":"NIST NVD usage terms; underlying source attribution retained","enrichment":{"sourceStatus":"Analyzed","weaknesses":["CWE-79"],"productCriteria":["cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:*"],"sourceDates":{"published":"2026-05-13T18:16:18.260","lastModified":"2026-06-17T10:50:49.770"},"relatedAdvisories":[],"note":"NVD analysis and CPE criteria are source context, not proof that a package or your environment is affected. Complete affected data, logical configurations and SSVC are retained in the original JSON."},"key":"nvd:CVE-2026-44580","identifiers":["CVE-2026-44580"]},"retained":false,"historicalAffected":[]}],"coverage":[]}