{"id":"CVE-2026-44981","revision":"a2ad6eeace6e4b0a920ed9545020d5cf","records":[{"revision":"a2ad6eeace6e4b0a920ed9545020d5cf","observedAt":"2026-10-23T15:48:27.903+00:00","statement":{"source":"cve-program","id":"CVE-2026-44981","aliases":[],"title":"CrowdSec LAPI: Denial of Service via Unbounded Gzip Decompression","description":"CrowdSec offers crowdsourced protection against malicious IPs. From 1.7.0 until 1.7.8, the LAPI router used gin-contrib/gzip with DefaultDecompressHandle globally in pkg/apiserver/controllers/controller.go, causing /v1/watchers and /v1/watchers/login to decompress unauthenticated gzip-compressed JSON request bodies without enforcing a maximum decompressed size and allowing excessive heap allocation that can make LAPI unreachable. This issue is fixed in version 1.7.8.","state":0,"publishedAt":"2026-07-16T19:47:30.747+00:00","modifiedAt":"2026-07-17T13:50:30.497+00:00","affected":[{"ecosystem":"Vendor product","name":"crowdsec","ranges":[],"versions":[],"rawVersionEvidence":"{\n                    \"vendor\": \"crowdsecurity\",\n                    \"product\": \"crowdsec\",\n                    \"versions\": [\n                        {\n                            \"version\": \">= 1.7.0, < 1.7.8\",\n                            \"status\": \"affected\"\n                        }\n                    ]\n                }"}],"metrics":[{"system":"CVSS 4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","score":8.2,"severity":"HIGH"}],"references":["https://github.com/crowdsecurity/crowdsec/security/advisories/GHSA-273h-gvwr-c3qj","https://github.com/crowdsecurity/crowdsec/commit/54a0dfe6c16b7687b0da6634e0b19ef0f5d9bb30","https://github.com/crowdsecurity/crowdsec/commit/56d0d6915f7f25941dc5b4f484028646f6601a37"],"sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-44981","license":"CVE Program Terms of Use","key":"cve-program:CVE-2026-44981","identifiers":["CVE-2026-44981"]},"retained":false,"historicalAffected":[]}],"coverage":[]}