{"id":"CVE-2026-48032","revision":"fcf20bf1b1fc40329373378fda1b2002","records":[{"revision":"fcf20bf1b1fc40329373378fda1b2002","observedAt":"2026-10-23T15:48:27.903+00:00","statement":{"source":"cve-program","id":"CVE-2026-48032","aliases":[],"title":"Hulumi: IAM-role policy checks bypassed when the role trusts multiple OIDC providers","description":"Hulumi is an open-source toolkit that ships secure-by-default cloud and platform infrastructure components for Pulumi. Prior to version 1.4.0, IAM-role policy checks can be bypassed when the role trusts multiple OIDC providers. This issue has been patched in version 1.4.0.","state":0,"publishedAt":"2026-07-24T18:39:05.061+00:00","modifiedAt":"2026-07-27T17:20:38.935+00:00","affected":[{"ecosystem":"Vendor product","name":"hulumi","ranges":[],"versions":[],"rawVersionEvidence":"{\n                    \"vendor\": \"kerberosmansour\",\n                    \"product\": \"hulumi\",\n                    \"versions\": [\n                        {\n                            \"version\": \"< 1.4.0\",\n                            \"status\": \"affected\"\n                        }\n                    ]\n                }"}],"metrics":[{"system":"CVSS 4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N","score":8.3,"severity":"HIGH"}],"references":["https://github.com/kerberosmansour/hulumi/security/advisories/GHSA-g759-4pxw-6692","https://github.com/kerberosmansour/hulumi/pull/178","https://github.com/kerberosmansour/hulumi/releases/tag/v1.4.0"],"sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-48032","license":"CVE Program Terms of Use","key":"cve-program:CVE-2026-48032","identifiers":["CVE-2026-48032"]},"retained":false,"historicalAffected":[]}],"coverage":[]}