{"id":"CVE-2026-84314","revision":"f509e65ac4a14e4f80faf16ed46994fd","records":[{"revision":"f509e65ac4a14e4f80faf16ed46994fd","observedAt":"2026-10-23T15:48:27.903+00:00","statement":{"source":"cve-program","id":"CVE-2026-84314","aliases":[],"title":"Nginx UI: Account Takeover via Missing `RequireSecureSession` on User Management Endpoint","description":"Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the POST /api/users/:id user-management endpoint permits an authenticated user to change another user's password without passing RequireSecureSession, even though the self-service password-change path requires that step-up. An attacker with an authenticated account can change the initial administrator's password, invalidate existing administrator tokens, and then authenticate as the administrator. This issue is fixed in version 2.4.1.","state":0,"publishedAt":"2026-10-12T20:47:51.561+00:00","modifiedAt":"2026-10-13T17:32:02.947+00:00","affected":[{"ecosystem":"Vendor product","name":"nginx-ui","ranges":[],"versions":[],"rawVersionEvidence":"{\n                    \"vendor\": \"0xJacky\",\n                    \"product\": \"nginx-ui\",\n                    \"versions\": [\n                        {\n                            \"version\": \"< 2.4.1\",\n                            \"status\": \"affected\"\n                        }\n                    ]\n                }"}],"metrics":[{"system":"CVSS 4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","score":8.7,"severity":"HIGH"}],"references":["https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-2gc7-j998-5xx6","https://github.com/0xJacky/nginx-ui/commit/23d1934099b05b2a01589b48129dc3d3159d91c2","https://github.com/0xJacky/nginx-ui/releases/tag/v2.4.1"],"sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-84314","license":"CVE Program Terms of Use","key":"cve-program:CVE-2026-84314","identifiers":["CVE-2026-84314"]},"retained":false,"historicalAffected":[]}],"coverage":[]}