{"id":"CVE-2026-84360","revision":"9ee3c4b370c74ac783a6a22f34393c06","records":[{"revision":"9ee3c4b370c74ac783a6a22f34393c06","observedAt":"2026-10-23T15:48:27.903+00:00","statement":{"source":"cve-program","id":"CVE-2026-84360","aliases":[],"title":"Nginx UI: OTP secure-session step-up can be bypassed via MCP configuration tools","description":"Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the HTTP configuration mutation routes require RequireSecureSession, but /mcp and /mcp_message require only ordinary authentication before exposing nginx_config_add and nginx_config_modify. An OTP-enabled user with a normal JWT but no valid X-Secure-Session-ID can therefore create or modify Nginx configuration and trigger reload behavior through MCP, bypassing the intended step-up control. This issue is fixed in version 2.4.1.","state":0,"publishedAt":"2026-10-12T21:08:04.687+00:00","modifiedAt":"2026-10-13T14:00:35.965+00:00","affected":[{"ecosystem":"Vendor product","name":"nginx-ui","ranges":[],"versions":[],"rawVersionEvidence":"{\n                    \"vendor\": \"0xJacky\",\n                    \"product\": \"nginx-ui\",\n                    \"versions\": [\n                        {\n                            \"version\": \"< 2.4.1\",\n                            \"status\": \"affected\"\n                        }\n                    ]\n                }"}],"metrics":[{"system":"CVSS 3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H","score":8.1,"severity":"HIGH"}],"references":["https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-vc32-4gwf-77xp","https://github.com/0xJacky/nginx-ui/commit/23d1934099b05b2a01589b48129dc3d3159d91c2","https://github.com/0xJacky/nginx-ui/releases/tag/v2.4.1"],"sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-84360","license":"CVE Program Terms of Use","key":"cve-program:CVE-2026-84360","identifiers":["CVE-2026-84360"]},"retained":false,"historicalAffected":[]}],"coverage":[]}