{"id":"EUVD-2026-25285","enisaUuid":"878ce56e-4ba1-3938-aaa8-ddf82c62237c","description":"Flowise is a drag \u0026 drop user interface to build a customized large language model flow. Prior to 3.1.0, Flowise is vulnerable to a critical unauthenticated remote command execution (RCE) vulnerability. It can be exploited via a parameter override bypass using the FILE-STORAGE:: keyword combined with a NODE_OPTIONS environment variable injection. This allows for the execution of arbitrary system commands with root privileges within the containerized Flowise instance, requiring only a single HTTP request and no authentication or knowledge of the instance. This vulnerability is fixed in 3.1.0.","datePublished":"Apr 23, 2026, 7:13:36 PM","dateUpdated":"Apr 23, 2026, 8:19:47 PM","baseScore":7.7,"baseScoreVersion":"3.0","baseScoreVector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L","references":"https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-cvrr-qhgw-2mm6\n","aliases":"CVE-2026-41268\n","assigner":"GitHub_M","epss":17.44,"enisaIdProduct":[{"id":"ee64e820-d272-3298-a626-c0bc57d38762","product":{"name":"Flowise","vendor":{"name":"FlowiseAI"}},"product_version":"\u003c 3.1.0"}],"enisaIdVendor":[{"id":"b0a961d1-db71-3a06-83ab-427a9b3cc66d","vendor":{"name":"FlowiseAI"}}],"enisaIdVulnerability":[{"id":"fa3ca597-a896-35ae-83b7-e29417f3f609","vulnerability":{"id":"CVE-2026-41268","description":"Flowise is a drag \u0026 drop user interface to build a customized large language model flow. Prior to 3.1.0, Flowise is vulnerable to a critical unauthenticated remote command execution (RCE) vulnerability. It can be exploited via a parameter override bypass using the FILE-STORAGE:: keyword combined with a NODE_OPTIONS environment variable injection. This allows for the execution of arbitrary system commands with root privileges within the containerized Flowise instance, requiring only a single HTTP request and no authentication or knowledge of the instance. This vulnerability is fixed in 3.1.0.","datePublished":"Apr 23, 2026, 7:13:36 PM","dateUpdated":"Apr 23, 2026, 8:19:47 PM","status":"PUBLISHED","baseScore":7.7,"baseScoreVersion":"3.0","baseScoreVector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L","references":"https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-cvrr-qhgw-2mm6\n","enisa_id":"EUVD-2026-25285\n","assigner":"GitHub_M","epss":17.44,"dataProcessed":"Nov 1, 2026, 7:18:11 AM","vulnerabilityProduct":[{"id":"feaeabce-025b-32c5-a477-59460d619020","product":{"name":"Flowise","vendor":{"name":"FlowiseAI"}},"product_version":"\u003c 3.1.0"}],"vulnerabilityVendor":[{"id":"09c12eea-d2d0-3999-86f0-ec8de6fc0eda","vendor":{"name":"FlowiseAI"}}]}}],"enisaIdAdvisory":[]}