{"id":"EUVD-2026-52795","enisaUuid":"decd47b2-8ac5-378b-83a7-430f386e4ae6","description":"Flowise is a drag \u0026 drop user interface to build a customized large language model flow. Prior to 3.1.3, the mitigation for CVE-2025-8943 blocked -y and --yes flags on npx, but packages/components/nodes/tools/MCP/core.ts denied only PATH, LD_LIBRARY_PATH, DYLD_LIBRARY_PATH, and NODE_OPTIONS by exact environment-variable name. Because npm reads configuration from npm_config_* variables, setting npm_config_yes\u003dtrue reproduced --yes behavior without using a blocked flag, causing npx to auto-install and execute the named package when a Custom MCP server launched. This issue is fixed in version 3.1.3.","datePublished":"Aug 4, 2026, 4:54:36 PM","dateUpdated":"Aug 4, 2026, 5:20:39 PM","baseScore":8.7,"baseScoreVersion":"4.0","baseScoreVector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","references":"https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-xc48-889x-5qmw\nhttps://github.com/FlowiseAI/Flowise/pull/6471\nhttps://github.com/FlowiseAI/Flowise/commit/a4c4e4988cded15edf725e762560575b889ae351\nhttps://github.com/FlowiseAI/Flowise/releases/tag/flowise@3.1.3\n","aliases":"CVE-2026-69263\nGHSA-xc48-889x-5qmw\n","assigner":"GitHub_M","epss":0.66,"enisaIdProduct":[{"id":"7c78c7ca-5687-38ac-a46a-ded16079bd6f","product":{"name":"Flowise","vendor":{"name":"FlowiseAI"}},"product_version":"\u003c 3.1.3"}],"enisaIdVendor":[{"id":"85118687-3487-39aa-b7fb-2a1185d9313a","vendor":{"name":"FlowiseAI"}}],"enisaIdVulnerability":[{"id":"9c427c85-09b1-3279-8d53-07c282abed67","vulnerability":{"id":"GHSA-xc48-889x-5qmw","description":"Flowise: CVE-2025-8943 Patch Bypass: npm_config_yes bypasses MCP environment variable blocklist (Unauthenticated RCE)","datePublished":"Aug 4, 2026, 5:09:48 PM","dateUpdated":"Aug 4, 2026, 5:09:48 PM","baseScore":0.0,"references":"https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-xc48-889x-5qmw\nhttps://github.com/FlowiseAI/Flowise/pull/6471\nhttps://github.com/FlowiseAI/Flowise/commit/a4c4e4988cded15edf725e762560575b889ae351\nhttps://github.com/FlowiseAI/Flowise\nhttps://github.com/FlowiseAI/Flowise/releases/tag/flowise@3.1.3\n","enisa_id":"EUVD-2026-52795\n","aliases":"GHSA-xc48-889x-5qmw\nCVE-2026-69263\n","epss":0.0,"dataProcessed":"Nov 1, 2026, 2:03:49 AM","vulnerabilityProduct":[],"vulnerabilityVendor":[]}},{"id":"f9251465-e3ac-35be-9315-4cac3333986d","vulnerability":{"id":"CVE-2026-69263","description":"Flowise is a drag \u0026 drop user interface to build a customized large language model flow. Prior to 3.1.3, the mitigation for CVE-2025-8943 blocked -y and --yes flags on npx, but packages/components/nodes/tools/MCP/core.ts denied only PATH, LD_LIBRARY_PATH, DYLD_LIBRARY_PATH, and NODE_OPTIONS by exact environment-variable name. Because npm reads configuration from npm_config_* variables, setting npm_config_yes\u003dtrue reproduced --yes behavior without using a blocked flag, causing npx to auto-install and execute the named package when a Custom MCP server launched. This issue is fixed in version 3.1.3.","datePublished":"Aug 4, 2026, 4:54:36 PM","dateUpdated":"Aug 4, 2026, 5:20:39 PM","status":"PUBLISHED","baseScore":8.7,"baseScoreVersion":"4.0","baseScoreVector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","references":"https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-xc48-889x-5qmw\nhttps://github.com/FlowiseAI/Flowise/pull/6471\nhttps://github.com/FlowiseAI/Flowise/commit/a4c4e4988cded15edf725e762560575b889ae351\nhttps://github.com/FlowiseAI/Flowise/releases/tag/flowise@3.1.3\n","enisa_id":"EUVD-2026-52795\n","assigner":"GitHub_M","epss":0.66,"dataProcessed":"Nov 3, 2026, 7:16:19 AM","vulnerabilityProduct":[{"id":"c11a7b61-c72f-37d1-babe-ae359c9bd901","product":{"name":"Flowise","vendor":{"name":"FlowiseAI"}},"product_version":"\u003c 3.1.3"}],"vulnerabilityVendor":[{"id":"3d5cdcc1-e961-346f-854d-97d8412a859a","vendor":{"name":"FlowiseAI"}}]}}],"enisaIdAdvisory":[]}