{"id":"GHSA-xgrm-4fwx-7qm8","revision":"c6b8d02dba74420a93b80a1d53974b08","records":[{"revision":"c6b8d02dba74420a93b80a1d53974b08","observedAt":"2026-10-24T13:19:41.952+00:00","statement":{"source":"osv","id":"GHSA-xgrm-4fwx-7qm8","aliases":["CVE-2026-33815","GO-2026-4771"],"title":"pgx contains memory-safety vulnerability","description":"[pgx](github.com/jackc/pgx/v5) is a pure Go driver and toolkit for PostgreSQL. pgx prior to v5.9.0 contains a memory-safety vulnerability.","state":0,"publishedAt":"2026-04-07T18:31:36+00:00","modifiedAt":"2026-09-10T03:50:44.892822+00:00","affected":[{"ecosystem":"Go","name":"github.com/jackc/pgx/v5","ranges":[{"type":"SEMVER","events":[{"kind":"introduced","version":"0"},{"kind":"fixed","version":"5.9.0"}]}],"versions":[],"rawVersionEvidence":null}],"metrics":[{"system":"CVSS_V3","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":null,"severity":null},{"system":"Publisher rating","vector":null,"score":null,"severity":"CRITICAL"}],"references":["https://nvd.nist.gov/vuln/detail/CVE-2026-33815","https://github.com/jackc/pgx/issues/2519","https://github.com/jackc/pgx/issues/2530","https://github.com/jackc/pgx/commit/6dbad4cafdb8a4daab7ff79c858c95da4b6109e8","https://pkg.go.dev/vuln/GO-2026-4771"],"sourceUrl":"https://github.com/advisories/GHSA-xgrm-4fwx-7qm8","license":"GitHub Advisory Database · CC-BY-4.0","key":"osv:GHSA-xgrm-4fwx-7qm8","identifiers":["GHSA-xgrm-4fwx-7qm8","CVE-2026-33815","GO-2026-4771"]},"retained":false,"historicalAffected":[]}],"coverage":[]}