@payloadcms/next has Stored XSS in Admin Panel
Exact source revision recorded 24 Oct 2026 13:17:17 UTC. It does not establish the source's current position. Latest evidence.
osv · GHSA-mmxc-95ch-2j7c
Published### Impact A stored Cross-site Scripting (XSS) vulnerability existed in the admin panel. An authenticated user with write access to a collection could save content that, when viewed by another user, would execute in their browser. Consumers are affected if ALL of these are true: - Payload version **< v3.78.0** - At least one collection with versions enabled - An authenticated user has `create` or `update` access to that collection ### Patches This vulnerability has been patched in **v3.78.0**. Output encoding has been added to prevent user-supplied content from being interpreted as markup. Users should upgrade to **v3.78.0** or later. ### Workarounds If consumers cannot upgrade immediately: - Restrict `create` and `update` access to versioned collections to trusted roles only.
- Source published
- 1 Apr 2026 21:24:22 UTC
- Source modified
- 6 Apr 2026 17:05:23 UTC
- Observed here
- 24 Oct 2026 13:17:17 UTC
- Source terms
- GitHub Advisory Database · CC-BY-4.0
Original source record · Cite this exact observation · Complete original publisher JSON
This view projects the publisher's source fields for reading; the original JSON retains additional fields and CVE enrichment containers. Attribution: osv · GitHub Advisory Database · CC-BY-4.0. Source text is retained; field grouping and change labels are provided by ChangeIntel.
CVSS_V3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
Publisher rating · HIGH